$re = '/.*\D(\d+\.\d+)/m';
$str = ' 1 675.04 318.26
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);