#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^-?\d{0,6}(\.\d{1,2})?$"
Local $sString = "123456.12" & @CRLF & _
"21231" & @CRLF & _
"123456" & @CRLF & _
"15465.43" & @CRLF & _
"23.34" & @CRLF & _
"6.45" & @CRLF & _
"12345678" & @CRLF & _
"123456.331" & @CRLF & _
"-10.10"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)