use strict;
my $str = '123456.12
21231
123456
15465.43
23.34
6.45
12345678
123456.331
-10.10';
my $regex = qr/^-?\d{0,6}(\.\d{1,2})?$/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";