#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]"
Local $sString = "[2020-03-07 01:02:37.512]ERROR [L:xx F:yy T:zz R: C: ] xxxxxxx xxxxx xxxx xxxx NullPointerException" & @CRLF & _
" at com.package.name(b.java:20)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:2423)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:40)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:4054)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[2020-03-07 01:02:37.512]ERROR [L:xx F:yy T:zz R: C: ] xxxxxxx xxxxx xxxx xxxxxxxx xxxxxxxxxxxxxxxx " & @CRLF & _
"xxxxxxxxx xxxxxxxxxxx xxxxxxxx xxxx xxxxxxxx xxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxx xxxx NullPointerException" & @CRLF & _
" at com.package.name(b.java:20)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:2423)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:40)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:4054)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[2020-03-07 01:02:37.512]ERROR [L:xx F:yy1 T:zz1 R: C: ] xxxxxxx xxxxx xxxx xxxx" & @CRLF & _
"[2020-03-07 01:03:37.512]ERROR [L:xx F:yy2 T:zz2 R: C: ] xxxxxxx xxxxx xxxx xxxx" & @CRLF & _
"[2020-03-07 01:04:37.512]ERROR [L:xx F:yy3 T:zz3 R: C: ] xxxxxxx xxxxx xxxx xxxx " & @CRLF & _
"[2020-03-07 01:05:37.512]ERROR [L:xx F:yy4 T:zz5 R: C: ] NullPointerException" & @CRLF & _
" at com.package.name(b.java:20)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:2423)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:40)" & @CRLF & _
" at com.package.name.someClass.someMethod(P.java:4054)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")