import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]";
final String string = "[2020-03-07 01:02:37.512]ERROR [L:xx F:yy T:zz R: C: ] xxxxxxx xxxxx xxxx xxxx NullPointerException\n"
+ " at com.package.name(b.java:20)\n"
+ " at com.package.name.someClass.someMethod(P.java:2423)\n"
+ " at com.package.name.someClass.someMethod(P.java:40)\n"
+ " at com.package.name.someClass.someMethod(P.java:4054)\n\n\n"
+ "[2020-03-07 01:02:37.512]ERROR [L:xx F:yy T:zz R: C: ] xxxxxxx xxxxx xxxx xxxxxxxx xxxxxxxxxxxxxxxx \n"
+ "xxxxxxxxx xxxxxxxxxxx xxxxxxxx xxxx xxxxxxxx xxxxxxxxxxxxxxxxxxxxxxxxxxx\n"
+ "xxxxxxxx xxxx NullPointerException\n"
+ " at com.package.name(b.java:20)\n"
+ " at com.package.name.someClass.someMethod(P.java:2423)\n"
+ " at com.package.name.someClass.someMethod(P.java:40)\n"
+ " at com.package.name.someClass.someMethod(P.java:4054)\n\n\n\n\n"
+ "[2020-03-07 01:02:37.512]ERROR [L:xx F:yy1 T:zz1 R: C: ] xxxxxxx xxxxx xxxx xxxx\n"
+ "[2020-03-07 01:03:37.512]ERROR [L:xx F:yy2 T:zz2 R: C: ] xxxxxxx xxxxx xxxx xxxx\n"
+ "[2020-03-07 01:04:37.512]ERROR [L:xx F:yy3 T:zz3 R: C: ] xxxxxxx xxxxx xxxx xxxx \n"
+ "[2020-03-07 01:05:37.512]ERROR [L:xx F:yy4 T:zz5 R: C: ] NullPointerException\n"
+ " at com.package.name(b.java:20)\n"
+ " at com.package.name.someClass.someMethod(P.java:2423)\n"
+ " at com.package.name.someClass.someMethod(P.java:40)\n"
+ " at com.package.name.someClass.someMethod(P.java:4054)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}