re = /\S+$/m
str = '6,300.69 22,359.06 11,712.20 40,371.95 0.00 0.00 0.00 40,371.95
40,371.95'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end