// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+$").unwrap();
let string = "6,300.69 22,359.06 11,712.20 40,371.95 0.00 0.00 0.00 40,371.95
40,371.95";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}