re = /^(?!(?:[ab]*c){1,2}[ab]*$)(?=(?:[bc]*a){3})(?:[ac]*b){3}[abc]*$/m
str = 'aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbbc
aabbb
abbccc
abcabca
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end