package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^-]*) - ([^-]*) - ([^-]*)$`)
var str = `some text - more text - yet more.txt
some text - more text.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}