re = /^([^-]*) - ([^-]*) - ([^-]*)$/m
str = 'some text - more text - yet more.txt
some text - more text.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end