$re = '/(\d+\.\d+)\s/m';
$str = '165.1 x 75.6 x 8.9 mm (6.5 x 2.98 x 0.35 in)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);