import re
regex = re.compile(r"(\d+\.\d+)\s", flags=re.MULTILINE)
test_str = "165.1 x 75.6 x 8.9 mm (6.5 x 2.98 x 0.35 in)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")