$re = '/(?:<([a-z]+)>(.*)<\/\1>)|((?:(?!<[a-z]+>.*<\/[a-z]+>).)+)/m';
$str = 'This is <yellow>message</yellow> that needs <green>to be formatted</green>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);