#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(?:as|AS))\s+[^\s.,\(\)\-=]+(?:\s*)|[^\s.,\(\)\-=][^\s.,\(\)\-=]+\s*(?==)"
Local $sString = "anp_t3.PREIS AS ANP_LEIH_PREIS, anp_t3.WAEHRUNG as ANP_LEIH_WAEHRUNG, anp_t3.BIS as ANP_LEIH_BIS, TESTWERT = t1.VALUE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")