#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?://\S+/)[^\s/]+/"
Local $sString = "https://int.soccerway.com/national/czech-republic/czech-liga/20192020/championship-round/r54505/" & @CRLF & _
"https://int.soccerway.com/national/england/championship/20192020/regular-season/r53782/" & @CRLF & _
"https://int.soccerway.com/national/finland/veikkausliiga/2020/regular-season/r56520/" & @CRLF & _
"https://int.soccerway.com/national/germany/play-offs-12/20192020/s17666/" & @CRLF & _
"https://int.soccerway.com/national/germany/play-offs-23/20192020/s17670/" & @CRLF & _
"https://int.soccerway.com/national/norway/1-division/2020/regular-season/r56858/" & @CRLF & _
"https://int.soccerway.com/national/sweden/superettan/2020/s18293/" & @CRLF & _
"https://int.soccerway.com/national/united-states/nwsl-challenge-cup/2020/preliminary-round/r58293/" & @CRLF & _
"" & @CRLF & _
"https://int.soccerway.com/national/czech-republic/czech-liga/20192020/championship-round/" & @CRLF & _
"https://int.soccerway.com/national/england/championship/20192020/regular-season/" & @CRLF & _
"https://int.soccerway.com/national/finland/veikkausliiga/2020/regular-season/" & @CRLF & _
"https://int.soccerway.com/national/germany/play-offs-12/20192020/" & @CRLF & _
"https://int.soccerway.com/national/germany/play-offs-23/20192020/" & @CRLF & _
"https://int.soccerway.com/national/norway/1-division/2020/regular-season/" & @CRLF & _
"https://int.soccerway.com/national/sweden/superettan/2020/" & @CRLF & _
"https://int.soccerway.com/national/united-states/nwsl-challenge-cup/2020/preliminary-round/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")