package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?://\S+/)[^\s/]+/`)
var str = `https://int.soccerway.com/national/czech-republic/czech-liga/20192020/championship-round/r54505/
https://int.soccerway.com/national/england/championship/20192020/regular-season/r53782/
https://int.soccerway.com/national/finland/veikkausliiga/2020/regular-season/r56520/
https://int.soccerway.com/national/germany/play-offs-12/20192020/s17666/
https://int.soccerway.com/national/germany/play-offs-23/20192020/s17670/
https://int.soccerway.com/national/norway/1-division/2020/regular-season/r56858/
https://int.soccerway.com/national/sweden/superettan/2020/s18293/
https://int.soccerway.com/national/united-states/nwsl-challenge-cup/2020/preliminary-round/r58293/
https://int.soccerway.com/national/czech-republic/czech-liga/20192020/championship-round/
https://int.soccerway.com/national/england/championship/20192020/regular-season/
https://int.soccerway.com/national/finland/veikkausliiga/2020/regular-season/
https://int.soccerway.com/national/germany/play-offs-12/20192020/
https://int.soccerway.com/national/germany/play-offs-23/20192020/
https://int.soccerway.com/national/norway/1-division/2020/regular-season/
https://int.soccerway.com/national/sweden/superettan/2020/
https://int.soccerway.com/national/united-states/nwsl-challenge-cup/2020/preliminary-round/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}