using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=clients_field_)(.*)(?=:)";
string substitution = @"";
string input = @"{
""success"": true,
""companies"" [
{
""clients_field_15bb4d92-0a64-4431-b9f6-d16873f808dd"": ""true"",
""clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6"": ""info@domain.com"",
""clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b"": ""2017-07-26"",
""clients_field_e5b4ca25-363e-4421-8198-e446207c4fb0"": ""2017-07-28""
},
{
""clients_field_15bb4d92-0a64-4431-b9f6-d16873f808dd"": ""true"",
""clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6"": ""info@domain.com"",
""clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b"": ""2017-07-26"",
""clients_field_e5b4ca25-363e-4421-8198-e446207c4fb0"": ""2017-07-28""
}
]
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}