# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=clients_field_)(.*)(?=:)"
test_str = ("{\n"
" \"success\": true,\n"
" \"companies\" [\n"
" {\n"
" \"clients_field_15bb4d92-0a64-4431-b9f6-d16873f808dd\": \"true\",\n"
" \"clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6\": \"info@domain.com\",\n"
" \"clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b\": \"2017-07-26\",\n"
" \"clients_field_e5b4ca25-363e-4421-8198-e446207c4fb0\": \"2017-07-28\"\n"
" },\n"
" {\n"
" \"clients_field_15bb4d92-0a64-4431-b9f6-d16873f808dd\": \"true\",\n"
" \"clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6\": \"info@domain.com\",\n"
" \"clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b\": \"2017-07-26\",\n"
" \"clients_field_e5b4ca25-363e-4421-8198-e446207c4fb0\": \"2017-07-28\"\n"
" }\n"
" ]\n"
"}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.