#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Event:\s+Task_(\d+)Error:(NO_ERROR|ERROR_(?:MINOR|\d+))(?:\w+:(\w+))?"
Local $sString = "Event: Task_01Error:NO_ERROR" & @CRLF & _
"Event: Task_01Error:ERROR_MINOR" & @CRLF & _
"Event: Task_02Error:NO_ERROR" & @CRLF & _
"Event: Task_03Error:ERROR_01Details:BadData" & @CRLF & _
"Event: Task_03Error:ERROR_MINOR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")