import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Event:\\s+Task_(\\d+)Error:(NO_ERROR|ERROR_(?:MINOR|\\d+))(?:\\w+:(\\w+))?";
final String string = "Event: Task_01Error:NO_ERROR\n"
+ "Event: Task_01Error:ERROR_MINOR\n"
+ "Event: Task_02Error:NO_ERROR\n"
+ "Event: Task_03Error:ERROR_01Details:BadData\n"
+ "Event: Task_03Error:ERROR_MINOR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}