$re = '/(\^{1,2})([0-7]{1,2})([a-zA-Z]+)/';
$str = '^1Piros^^2Zold^^06Sarga^3-=98';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);