#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(1234[\w ]+(Word \w+))((?:(?!1234)[\s\S])*)"
Local $sString = "1234_This is a text Word AB" & @CRLF & _
"" & @CRLF & _
"Protocol Address ping" & @CRLF & _
"Internet 1.1.1.1 - " & @CRLF & _
"Internet 1.1.1.2 25 " & @CRLF & _
"Internet 1.1.1.3 8 " & @CRLF & _
"Internet 1.1.1.4 - " & @CRLF & _
"" & @CRLF & _
"1234_This is a text Word BCD " & @CRLF & _
"Protocol Address ping" & @CRLF & _
"Internet 2.2.2.1 10 " & @CRLF & _
"Internet 2.2.2.2 - "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")