re = /(1234[\w ]+(Word \w+))((?:(?!1234)[\s\S])*)/
str = '1234_This is a text Word AB
Protocol Address ping
Internet 1.1.1.1 -
Internet 1.1.1.2 25
Internet 1.1.1.3 8
Internet 1.1.1.4 -
1234_This is a text Word BCD
Protocol Address ping
Internet 2.2.2.1 10
Internet 2.2.2.2 - '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end