import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(1234[\\w ]+(Word \\w+))((?:(?!1234).)*)";
final String string = "1234_This is a text Word AB\n\n"
+ "Protocol Address ping\n"
+ "Internet 1.1.1.1 - \n"
+ "Internet 1.1.1.2 25 \n"
+ "Internet 1.1.1.3 8 \n"
+ "Internet 1.1.1.4 - \n\n"
+ "1234_This is a text Word BCD \n"
+ "Protocol Address ping\n"
+ "Internet 2.2.2.1 10 \n"
+ "Internet 2.2.2.2 - ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}