# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(1234[\w ]+(Word \w+))((?:(?!1234).)*)"
test_str = ("1234_This is a text Word AB\n\n"
"Protocol Address ping\n"
"Internet 1.1.1.1 - \n"
"Internet 1.1.1.2 25 \n"
"Internet 1.1.1.3 8 \n"
"Internet 1.1.1.4 - \n\n"
"1234_This is a text Word BCD \n"
"Protocol Address ping\n"
"Internet 2.2.2.1 10 \n"
"Internet 2.2.2.2 - ")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.