# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?(?=(acme|broadway))\1|[\w\s])+?$//gim;t' <<< "ACME Corp 123
Corp 742 ACME
Random Text
Broadway 1785 FB"