$re = '/^(?(?=(acme|broadway))\1|[\w\s])+?$/im';
$str = 'ACME Corp 123
Corp 742 ACME
Random Text
Broadway 1785 FB';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;