package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)@loop \((.*?)\) \{(.*?)\}`)
    var str = `@loop (<ВЗЯТЬ ЭТОТ ТЕКCТ>) {<ВЗЯТЬ ЭТОТ ТЕКCТ>}`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}