$re = '/@loop \((.*?)\) \{(.*?)\}/m';
$str = '@loop (<ВЗЯТЬ ЭТОТ ТЕКCТ>) {<ВЗЯТЬ ЭТОТ ТЕКCТ>}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);