#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<=RIASWIX).*?(?=Sky Access)"
Local $sString = "----Document Start-------" & @CRLF & _
"" & @CRLF & _
"Paragraph*" & @CRLF & _
"" & @CRLF & _
"RIASWIX.* ABCDEF1 NONE" & @CRLF & _
" WORKING: HELLO(READ)" & @CRLF & _
" BOOLEAN Access: SADGRE3, VJFKES3, JGJKEWW, IS4DWF44(A), DFEAWE2(G)," & @CRLF & _
" DW4444W, IHFK3MF3" & @CRLF & _
" BAZAAR Access: No resource with BAZAAR Access" & @CRLF & _
" GHAR Access: No resource with GHAR Access" & @CRLF & _
" WATER Access: ADMINDDD(A), GEDDE33" & @CRLF & _
" SKY None: No Resource with Sky Access" & @CRLF & _
"" & @CRLF & _
"RIASWIX.@7483NFJ.* HFDFDF3 NONE" & @CRLF & _
" WORKING: BYE(READ)" & @CRLF & _
" BOOLEAN Access: GRREGGG, GREFEFF, GFGGGG, FDFDFDF(A), RERERE3(G)," & @CRLF & _
" GFFWEF44, FFRF44F" & @CRLF & _
" BAZAAR Access: No resource with BAZAAR Access" & @CRLF & _
" GHAR Access: No resource with GHAR Access" & @CRLF & _
" WATER Access: ADMINEWW(A), FFRFRGR" & @CRLF & _
" SKY None: No Resource with Sky Access" & @CRLF & _
"" & @CRLF & _
"RIASWIX.@7483KXX.* HFDFDF3 NONE" & @CRLF & _
" WORKING: TATA(READ)" & @CRLF & _
" BOOLEAN Access: GRDSD33, FASDE, GFGGGG, RWERW33(A), NMUYHT4(G)," & @CRLF & _
" BAZAAR Access: XCDFEFE3, FREFE33R" & @CRLF & _
" GHAR Access: No resource with GHAR Access" & @CRLF & _
" WATER Access: DASDEFG(A), SJMFEIOE(P)" & @CRLF & _
" SKY None: No Resource with Sky Access" & @CRLF & _
"" & @CRLF & _
"*Text" & @CRLF & _
"" & @CRLF & _
"----Document End-------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")