import re
regex = re.compile(r"(?<=RIASWIX).*?(?=Sky Access)", flags=re.MULTILINE | re.DOTALL)
test_str = ("----Document Start-------\n\n"
"Paragraph*\n\n"
"RIASWIX.* ABCDEF1 NONE\n"
" WORKING: HELLO(READ)\n"
" BOOLEAN Access: SADGRE3, VJFKES3, JGJKEWW, IS4DWF44(A), DFEAWE2(G),\n"
" DW4444W, IHFK3MF3\n"
" BAZAAR Access: No resource with BAZAAR Access\n"
" GHAR Access: No resource with GHAR Access\n"
" WATER Access: ADMINDDD(A), GEDDE33\n"
" SKY None: No Resource with Sky Access\n\n"
"RIASWIX.@7483NFJ.* HFDFDF3 NONE\n"
" WORKING: BYE(READ)\n"
" BOOLEAN Access: GRREGGG, GREFEFF, GFGGGG, FDFDFDF(A), RERERE3(G),\n"
" GFFWEF44, FFRF44F\n"
" BAZAAR Access: No resource with BAZAAR Access\n"
" GHAR Access: No resource with GHAR Access\n"
" WATER Access: ADMINEWW(A), FFRFRGR\n"
" SKY None: No Resource with Sky Access\n\n"
"RIASWIX.@7483KXX.* HFDFDF3 NONE\n"
" WORKING: TATA(READ)\n"
" BOOLEAN Access: GRDSD33, FASDE, GFGGGG, RWERW33(A), NMUYHT4(G),\n"
" BAZAAR Access: XCDFEFE3, FREFE33R\n"
" GHAR Access: No resource with GHAR Access\n"
" WATER Access: DASDEFG(A), SJMFEIOE(P)\n"
" SKY None: No Resource with Sky Access\n\n"
"*Text\n\n"
"----Document End-------")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")