use strict;
my $str = '{\\"ref\\":\\"Session_1___Pg1___V2\\",\\"pageTitle\\":null,\\"description\\":null,\\"revealDate\\":0,\\"gQRef\\":null,\\"lQRef\\":null,\\"gQScore\\":null,\\"lQScore\\":null,\\"newsfeedDates\\":null,\\"subtitle\\":null,\\"pageLinkTitle\\":null,\\"linkTitle\\":null,\\"pageBack\\":null,\\"pagePrint\\":false,\\"visitedFlag\\":null,\\"widthPercentage\\":0,\\"maxWidth\\":0,\\"thumbnail\\":null,\\"edit\\":null,\\"copy\\":null,\\"delete\\":null,\\"preview\\":null}]}';
my $regex = qr/(?<=\\"ref\\":\\)"([^"]+)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}