package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{(?:[^{}]+|(?R))+\}`)
var str = `struct my_struct{
double d;
struct {int i;, char c;} s;
};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}