$re = '~\{(?:[^{}]+|(?R))+\}~m';
$str = 'struct my_struct{
double d;
struct {int i;, char c;} s;
};';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);