import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "total\\s+amount\\s*(?::\\s*)?\\d[\\d,.]*+(?!\\s*kgs)";
final String string = "task1. total amount 5,887.99 kgs\n"
+ "task2. total amount 5,887.99kgs\n"
+ "task3. total amount 5,887.99 usd\n"
+ "task4. total amount 5,887.99usd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}