$re = '/total\s+amount\s*(?::\s*)?\d[\d,.]*+(?!\s*kgs)/mi';
$str = 'task1. total amount 5,887.99 kgs
task2. total amount 5,887.99kgs
task3. total amount 5,887.99 usd
task4. total amount 5,887.99usd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);