$re = '/\b(?!v1|key1|another|key2)\w+\b/';
$str = 'v1, key1, another, key2, something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);