re = /\b(?!v1|key1|another|key2)\w+\b/
str = 'v1, key1, another, key2, something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end