package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)([A-Z][A-Z0-9]+-[0-9]+)`)
var str = `Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
test: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
hallo: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}