$re = '/([A-Z][A-Z0-9]+-[0-9]+)/mx';
$str = 'Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
test: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
hallo: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);