using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(www\.)?twitter\.com\/(#!\/)?@?(?<name>[^\/]+)(\/\w+)*$";
string input = @"https://twitter.com/#!/@tweet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}