re = /^https?:\/\/(www\.)?twitter\.com\/(#!\/)?@?(?<name>[^\/]+)(\/\w+)*$/m
str = 'https://twitter.com/#!/@tweet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end