re = /\{value\=(([a-z|A-Z|(0-9)*|\s+|\w+]*))\}\}/m
str = '{value=Parking Bay Suspension}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end