#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)(?:^|\s)(((?:\+|0{2})(?:49|43|33)[-\. ]?|0)([1-9]\d{1,2}[-\. ]?|\([1-9]\d{1,2}\)[-\. ]?)(\d{6,9}|\d{2,3}[-\. ]\d{4,6}))"
Local $sString = "+33 100 000 0000" & @CRLF & _
"000-000-0000" & @CRLF & _
"000 000 0000" & @CRLF & _
"000.000.0000" & @CRLF & _
"" & @CRLF & _
"12000-000-000012" & @CRLF & _
"12000 000 000012" & @CRLF & _
"12000.000.000012" & @CRLF & _
"" & @CRLF & _
"0049-000-0000" & @CRLF & _
"000 000 0000" & @CRLF & _
"000.000.0000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(000)000-0000" & @CRLF & _
"(000)000 0000" & @CRLF & _
"(000)000.0000" & @CRLF & _
"(000) 000-0000" & @CRLF & _
"(000) 000 0000" & @CRLF & _
"(000) 000.0000" & @CRLF & _
"" & @CRLF & _
"12(000)000-000012" & @CRLF & _
"12(000)000 000012" & @CRLF & _
"12(000)000.000012" & @CRLF & _
"12(000) 000-000012" & @CRLF & _
"12(000) 000 000012" & @CRLF & _
"12(000) 000.000012" & @CRLF & _
"" & @CRLF & _
"000-0000" & @CRLF & _
"000 0000" & @CRLF & _
"000.0000" & @CRLF & _
"0000000" & @CRLF & _
"(100)0000000" & @CRLF & _
"" & @CRLF & _
"12000-000012" & @CRLF & _
"12000 000012" & @CRLF & _
"12000.000012" & @CRLF & _
"12000000012" & @CRLF & _
"12(000)000000012" & @CRLF & _
"" & @CRLF & _
"+28 100 000 0000" & @CRLF & _
"+33 000 000 0000" & @CRLF & _
"+33 100 000 0000" & @CRLF & _
"+49 100 000 0000" & @CRLF & _
"+43 100 000 0000" & @CRLF & _
"+43.100.000.0000" & @CRLF & _
"+43-100-000-0000" & @CRLF & _
"+43 100 000 0000" & @CRLF & _
"+43.100.000.0000" & @CRLF & _
"+43-100-000-0000" & @CRLF & _
"+433 100 000 0000" & @CRLF & _
"+433.100.000.0000" & @CRLF & _
"+433-100-000-0000" & @CRLF & _
"+433000000000" & @CRLF & _
"0043 1000000000" & @CRLF & _
"0043 100000000000023" & @CRLF & _
"0043 100000" & @CRLF & _
"0043 100000000" & @CRLF & _
"0043 100 00 00000" & @CRLF & _
"0043 100 000 0000" & @CRLF & _
"0043-100-000-0000" & @CRLF & _
"00431000000000" & @CRLF & _
"0000-000-000-0000" & @CRLF & _
"00000000000000" & @CRLF & _
"+43 (100)000 0000" & @CRLF & _
"0043 (100)000-0000" & @CRLF & _
"0043(100)000-0000" & @CRLF & _
"0000 (100)000-0000" & @CRLF & _
"0000(100)000-0000" & @CRLF & _
"+43 (100) 000 0000" & @CRLF & _
"0043 (100) 000-0000" & @CRLF & _
"0043(100) 000-0000" & @CRLF & _
"0000 (100) 000-0000" & @CRLF & _
"0000(100) 000-0000" & @CRLF & _
"+43 (10)000 0000" & @CRLF & _
"0043 (10)000-0000" & @CRLF & _
"0043(10)000-0000" & @CRLF & _
"0000 (10)000-0000" & @CRLF & _
"0000(10)000-0000" & @CRLF & _
"+43 (10) 000 0000" & @CRLF & _
"0043 (10) 000-0000" & @CRLF & _
"0043(10) 000-0000" & @CRLF & _
"0000 (10) 000-0000" & @CRLF & _
"0000(10) 000-0000" & @CRLF & _
"" & @CRLF & _
"0662 874278" & @CRLF & _
"0676 7359567" & @CRLF & _
"" & @CRLF & _
"0343545435343" & @CRLF & _
"" & @CRLF & _
"06700000023" & @CRLF & _
"" & @CRLF & _
"12+43 100 000 000012" & @CRLF & _
"12+43.100.000.000012" & @CRLF & _
"12+43-100-000-000012" & @CRLF & _
"12+43100000000012" & @CRLF & _
"120043 100000000012" & @CRLF & _
"120043-100-000-000012" & @CRLF & _
"120043100000000012" & @CRLF & _
"12+43 (100)000 000012" & @CRLF & _
"120043 (100)000-000012" & @CRLF & _
"120043(100)000-000012" & @CRLF & _
"" & @CRLF & _
"+49 10 000000" & @CRLF & _
"(000) 0000-0000" & @CRLF & _
"(0000) 0000-0000" & @CRLF & _
"(00000) 000-0000" & @CRLF & _
"(030000) 00-0000" & @CRLF & _
"01200-0000000" & @CRLF & _
"0137-000 0000000" & @CRLF & _
"01500-0000000" & @CRLF & _
"0160-0000000" & @CRLF & _
"0170-0000000" & @CRLF & _
"032-000000000" & @CRLF & _
"0700-0000000" & @CRLF & _
"0800-0000000" & @CRLF & _
"0900-0-000000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0000000000000" & @CRLF & _
"0000000000000" & @CRLF & _
"" & @CRLF & _
"120000000000000" & @CRLF & _
"120000000000000" & @CRLF & _
"" & @CRLF & _
"+00+00 000 0000" & @CRLF & _
"" & @CRLF & _
"2013 175000km" & @CRLF & _
"019 55000km"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")