$re = '/<(?P<name>\s*.+?\s*):(?P<value>\s*.+?\s*)>/';
$str = 'user/auth/<id: INT>/<password: STR>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);