re = /<(?P<name>\s*.+?\s*):(?P<value>\s*.+?\s*)>/
str = 'user/auth/<id: INT>/<password: STR>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end