using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^,]+),";
string input = @"[""teads.tv, 15429, reseller, 15a9c44f6d26cbe1 "",""video.unrulymedia.com,367782854,reseller"",""google.com, pub-8173359565788166, direct, f08c47fec0942fa0"",""google.com, pub-8804303781641925, reseller, f08c47fec0942fa0 ""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}