// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"([^,]+),"#).unwrap();
let string = "[\"teads.tv, 15429, reseller, 15a9c44f6d26cbe1 \",\"video.unrulymedia.com,367782854,reseller\",\"google.com, pub-8173359565788166, direct, f08c47fec0942fa0\",\"google.com, pub-8804303781641925, reseller, f08c47fec0942fa0 \"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}