using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(big|needle1)";
string input = @"this-is-big-needle1.jpg
this-needle1-is-big.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}