$re = '/(big|needle1)/m';
$str = 'this-is-big-needle1.jpg
this-needle1-is-big.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);